Auto tool changer

martin

Martin
Hi,
I have prepared the auto tool changer and it works well, only at the end of the cycle the Z axis goes up to the hard limit.
I don't understand a thing about this and I don't know what else to do.
I have drawn a circle with two operations (2 bits) in Aspire.

Someone the solution?
 

Attachments

  • test-rondje.nc
    1.5 KB · Views: 15
  • MASSO_Settings.htg
    688 bytes · Views: 13
  • MASSO_Tools.htg
    1.9 KB · Views: 12

breezy

Arie
Staff member
@martin

What is the travel of your Z axis?

What is the distance from your WCS Z zero to the hard stop?

The reason for these questions is that at the end of the second operation the end mill is lifted to Z15 on line N530 then on the next line Z is sent to Z49.

I don't know much about Aspire but with Fusion the end of the file contains this code block.
N4285 G0 Z15.​

N4290 G28 G91 Z0.
N4295 G90
N4300 G28 G91 X0. Y0.
N4305 G90
N4310 M30​

So N4285 is the end of the last operation and lifts the cutter to Z15 above the job WCS. Then the G28 in the next line tells MASSO to move to the Z home position and the following lines move the head to the X & Y home. Then stop and rewind file.

Hope this helps you to work out why Aspire is sending the head into the Z hard stop.

Regards,

Arie.
 

cncnutz

CNCnutz
Staff member
Hi @martin

I loaded your settings file and see that you are not using soft limits but Hard limits only.

This is a little unusual as you should use Soft limits to keep the axis within bounds and only use hard limits as a last resort in case the soft limits fail.

Can you be a little more specific about when you get the Hard Limit alarm? What line is showing when the hard limit occurs? Is it failing as part of the tool change routine or is it while it is machining and moving to Z49 as Arie mentions?


Is your homing switch within the envelope of Z axis travel or is it on the end?

Cheers

Peter
 

martin

Martin
Quote from Breezy on September 12, 2019, 12:25 am

@martin

What is the travel of your Z axis?

What is the distance from your WCS Z zero to the hard stop?

The reason for these questions is that at the end of the second operation the end mill is lifted to Z15 on line N530 then on the next line Z is sent to Z49.

I don't know much about Aspire but with Fusion the end of the file contains this code block.
N4285 G0 Z15.​

N4290 G28 G91 Z0.
N4295 G90
N4300 G28 G91 X0. Y0.
N4305 G90
N4310 M30​

So N4285 is the end of the last operation and lifts the cutter to Z15 above the job WCS. Then the G28 in the next line tells MASSO to move to the Z home position and the following lines move the head to the X & Y home. Then stop and rewind file.

Hope this helps you to work out why Aspire is sending the head into the Z hard stop.

Regards,

Arie.

Thank you Arie for your help, this makes it a bit clearer again.
I now understand that it is not the Masso but Vectric.
I don't understand where the z49 comes from, if I do the same in Cut2D pro, then I don't see the 49 in the code. It also works well with cnc.
For now I just change the Z via Ctrl E, it's not how it should be but otherwise I don't know.

Can this code / routine also be implanted in the masso?
Maybe in the postprocessor?

N4285 G0 Z15.

N4290 G28 G91 Z0.
N4295 G90
N4300 G28 G91 X0. Y0.
N4305 G90
N4310 M30

Thank you for your help.

Greetings Martin
 

breezy

Arie
Staff member
The Z49 generated by Vectric is because of some setting in Aspire. As I said before I don't know much about Aspire, but Peter of CNCNUTZ fame is the Vectric expert on this forum. Maybe he can modify the Aspire post processor to include G28 commands at the end of the operations to safely park the head of your CNC Mill.

We can't help any more without more details about your setup. Both Peter and I have asked for details which you haven't answered.

Soft limits are important they will throw an alarm before the MASSO will move your mill if the gcode commands exceed the travel limits.

Regards,

Arie.
 

cncnutz

CNCnutz
Staff member
Hi Martin,

On Tool paths screen you will find at the top the Material setup and if you select this you will see the Gap above Material at the very bottom.

I think this is where you will find your 49mm is located. I keep mine set to 20mm. This should solve your issue.

You can easily modify the post processor to include a G28 if you wish but you shouldn't need to. Just open the post process in wordpad and add the Gcode before the line M30 if you want and save it. Vectric post processors are easy to modify and easy to understand.

Cheers

Peter
 

Attachments

  • Z-Height.png
    Z-Height.png
    32.2 KB · Views: 16

martin

Martin
Quote from CNCnutz on September 14, 2019, 1:22 am

Hi Martin,

On Tool paths screen you will find at the top the Material setup and if you select this you will see the Gap above Material at the very bottom.

I think this is where you will find your 49mm is located. I keep mine set to 20mm. This should solve your issue.

You can easily modify the post processor to include a G28 if you wish but you shouldn't need to. Just open the post process in wordpad and add the Gcode before the line M30 if you want and save it. Vectric post processors are easy to modify and easy to understand.

Cheers

Peter

Hi Peter,

Thank you for your help, now I see what it has been like. I adjusted it and it works well now.

Every day I learn more, thanks to your help on this forum.

In your earlier answer about the soft limits you said that I had not set them, but as far as I know I did.
Soft limits are automatically set by the min / max of the axes?

The cnc is also doing well.

Thank you again Peter.
 

martin

Martin
Quote from Breezy on September 13, 2019, 12:14 pm

The Z49 generated by Vectric is because of some setting in Aspire. As I said before I don't know much about Aspire, but Peter of CNCNUTZ fame is the Vectric expert on this forum. Maybe he can modify the Aspire post processor to include G28 commands at the end of the operations to safely park the head of your CNC Mill.

We can't help any more without more details about your setup. Both Peter and I have asked for details which you haven't answered.

Soft limits are important they will throw an alarm before the MASSO will move your mill if the gcode commands exceed the travel limits.

Regards,

Arie.

Hello Arie,

Thank you for your answer.
The machine is also doing fine, and I think the soft limits are set.
In this case it was due to a wrong number entered in Vectric.

Peter was able to make it clear to me with the image of vectric.

For now it works fine.

Thanks a lot for your help.

Cheers, Martin.
 

cncnutz

CNCnutz
Staff member
Hi @martin

Glad you got it sorted.
Quote from Martin on September 14, 2019, 8:29 am

In your earlier answer about the soft limits you said that I had not set them, but as far as I know I did.
Soft limits are automatically set by the min / max of the axes?

You did set maximum and minimum values in the axis which will limit your travel while jogging the machine but under general settings you then disabled soft limits while machining.

See the screen capture below.

Cheers

Peter
 

Attachments

  • Print-Screen-001.bmp
    769.1 KB · Views: 18
Top