Auto zero problem

vps

vps
Hello,

I tried to enable "Auto zero" but when my Y-axis minimum isn't Y0.00 Masso get stock in a "Homing wait" status

When Y0.00 is set Homing is almost OK except the homing coordinates stay X0.00 Y0.00 it should be X10.00 Y10.00

I need some help with this case



Ren
 

Attachments

  • 1-TravelMin7.6.bmp
    769.1 KB · Views: 9
  • 1-AutoToolSetup.bmp
    769.1 KB · Views: 14
  • 1-HomingWait.bmp
    769.1 KB · Views: 8
  • 2-TravelMin0.0.bmp
    769.1 KB · Views: 10
  • 2-HomingOK.bmp
    769.1 KB · Views: 9

masso-support

MASSO Support
Staff member
Hi @vps

I can't see what input you put the Toolsetter onto in you screen dumps. Can you show the tool setter input you setup please.

Also this video may help.

Cheers Peter

 

breezy

Arie
Staff member
Quote from vps on January 6, 2020, 4:43 pm

I tried to enable "Auto zero" but when my Y-axis minimum isn't Y0.00 Masso get stock in a "Homing wait" status

When Y0.00 is set Homing is almost OK except the homing coordinates stay X0.00 Y0.00 it should be X10.00 Y10.00

Ren ,

In your ATZ screen you need to enable (tick boxes) the X & Y axis for MASSO to move to the Tool Setter location.

Regards,

Arie.
 

vps

vps
Thanks Arie,

I did miss that one. But if I chance the "Travel minimum" otherwise than 0.000mm I get a homing "WaiT"status.

And I need 7.6mm from the Y- home switch because off the work area is smaller

the same issue on the X-axis but I don't need that one

Ren
 

breezy

Arie
Staff member
Ren ,

Set your minimum on axis to zero (0) then after homing, position the head to the start of your work area and go into F4 screen and set G54 X & Y using autoload (G54 is default WCS). This will set DRO X & Y to zero when you return to F2 or F3 screens. When you then issue X0 Y0 in MDI the head will travel to the edge of your work area. You can also position your ATZ to be outside your work area. This is what I do, so my ATZ point is outside the work envelope.

Regards,

Arie.
 

vps

vps
Thanks Arie,

I know that procedure, but I din't had this problem before auto zeroing and now I have.

Regards,



Ren
 

vps

vps
Hi Peter,

See config file,

I only chance travel minimum Y 7.600mm

The same happens when I set travel minimum X 7.600mm

Regards,

Ren
 

Attachments

  • MASSO_Settings.htg
    672 bytes · Views: 9

cncnutz

CNCnutz
Staff member
Hi @vps

I had a look at your files and you have setup your machine so that you have soft limit conflicts. Disable soft limits and I think you will find the Auto tool Zero will start working.

I cannot understand your setup but having your home position outside the envelope of axis travel is asking for trouble as Arie will tell you.

You also didn't setup the manual tool change position as per the video above as you have it set outside the area of travel so it gives an error when you try and close this page.

Please go through the 3 part video series I made showing how to set up homing, soft limits and finally the Auto Tool Zero in that order. I think it will solve your problem. You can always load the settings file if you are not happy with the results.

I am away for the next couple of days so will check back in when i can.

Cheers

Peter
 

Attachments

  • Print-Screen-002.bmp
    769.1 KB · Views: 18

vps

vps
Thank you Peter,

I'm not homing outside my envelope but I use a dust cover and that make my envelope smaller. That is why I want to chance my minimum travel.

Regards,

Ren
 

cncnutz

CNCnutz
Staff member
Hi @vps

Your home position is x0 yo but your minimum travel is x7. 6 y7. 6 so you cannot get to x0 y0 meaning your home position outside the envelope of travel. A G28 in your Gcode will cause soft limit alarms unless you disable soft limits.

Cheers

Peter
 

breezy

Arie
Staff member
Ren ,

I use a dust shoe and my work envelope is reduced because of it, but I have positioned the homing sensors so that the shoe clears the machine framework.

In this photo you can see the Y axis homing sensor is about 150mm from the front of the machine, down on the table near it is the aluminum plate for the ATZ and the wooden beads screwed to the table form the work envelope. I set G54 to the corner of the work envelope.

Regards,

Arie.
 

Attachments

  • Annotation-2020-01-09-140955.jpg
    Annotation-2020-01-09-140955.jpg
    53.2 KB · Views: 6

vps

vps
Thank you Arie,

My setup is almost the same.

I will go for the mechanical solution

Regards,

Ren
 
Top