Automatic Tool Height Setting for Mill

bjengle

bjengle
Hello,

Today I added a touch probe to my mill and it works great when issuing handwritten G-code with a file name: ZERO

G91

G38.2 Z-2 F10

G92 Z.5

Similar to how the video shows.

I then tried setting up the Auto Tool Setting feature and got it to mostly work. However after I manually change tools the spindle moves directly over the probing plate just like it should but then it doesn't engage in lowing the Z, instead it moves directly to the next line of G code. I can not seem to figure out why a T3 M6 tool change will not then move down and probe after changing the tool. Much help is appreciated. I will attach my G code files and settings.

I am using version 3.40.

Thank you!
 

Attachments

  • MASSO_Tools.htg
    1.9 KB · Views: 15
  • MASSO_Settings.htg
    620 bytes · Views: 17
  • ZERO.nc
    38 bytes · Views: 15
  • TOOLCHANGER.nc
    59 bytes · Views: 17

masso-support

MASSO Support
Staff member
from your toolcahnger.nc file is the issue happening after G01 X1 F40 line?

can you please give line numbers and explain the process.
 

bjengle

bjengle
I don't believe so. The code is for a simple square contour to be machined and then to change the tool from Tool 3 (T3) to Tool 4 (T4). I wrote the simple program just to test the automatic tool probing feature.

I am having trouble with the automatic zero probing. The end mill moves to the correct offset for the auto tool height plate, but then it does not initiate a downward Z movement which would then re probe a new tool and set the correct tool length.

Does the automatic tool height command in the Masso control happen when a tool change command is issued? like T3 M6? I hope this makes sense. the code is explained below.



N10 G20 (set to inches)
N20 T3 M6 (change tool to tool 3)

N30 G01 X1 F40 (linear 1 in in the x direction with a feed rate of 40 ipm)
N40 Y1 (move 1 in in the y direction)
N50 X-1
N60 Y-1

N70 T4 M6 (change tool to tool 4)
N80 G01 X1
N90 Y1
N100 X-1
N110 Y-1
 

bjengle

bjengle
Here are my current settings for the controller. I have enabled the auto tool zero option and typed in coordinates to where I would like it to zero at. Thank you
 

Attachments

  • MASSO_Settings.htg
    620 bytes · Views: 13

bjengle

bjengle
I have Manual Tool Change selected in the F1 Set up Screen. I Put together a video of what exactly is happening.

Here is the link to the youtube video


I hope this gives a better explanation. Also I have the 5 axis version and there have been times in the past you guys said the 5 axis version is sometimes buggy. Anyway thank you for the help!
 

breezy

Arie
Staff member
Been following, because we are having a problem with the auto tool length probe but our problem is different, in that turning auto probe on stops homing from completing.

Watched your video and I think I have spotted your problem. There are two touch probe inputs on MASSO, the one you have connected "Probe Input Signal" and "Tool Setter Input". It is Tool Setter that you need to use for auto tool length.

Regards,

Arie.
 

dsherburn

dsherburn
Wow...I think that's it. I was having the same problem and tested it on the bench. I think it works! (I had a parallel question here under "Auto Tool Zero and VCarve").

Thanks for looking...It was confusing to see the two choices.
 

bjengle

bjengle
That's great! I will try this fix tonight when I get home from work. So glad it's nothing major. Thankful for the MASSO community. You guys are so helpful!
 

bjengle

bjengle
Quote from Breezy on March 29, 2019, 1:26 am

Been following, because we are having a problem with the auto tool length probe but our problem is different, in that turning auto probe on stops homing from completing.

Watched your video and I think I have spotted your problem. There are two touch probe inputs on MASSO, the one you have connected "Probe Input Signal" and "Tool Setter Input". It is Tool Setter that you need to use for auto tool length.

Regards,

Arie.

WOW! It worked so helpful! Thank you guys!
 
Top