Axis calibration

rroie

rroie
Trying to calibrate the axis. Trying to set zero trips hard limits and can not clear without powering off Masso or homing which you can not do without calibration. Also Y + away from me both motors turn same direction. Y- toward me motors turn opposite direction. No limit switches besides homing switches? Just soft limits which I can not seem to get set? I thought this was going to me easy compared to Mach3. Need help.

Thank You

Roie
 

rroie

rroie
OK. got the axis going the right direction to home but only x axis homes the other just set off the limit proximity sw.
 

masso-support

MASSO Support
Staff member
Hi rroie

The homing switches double as limit switches.

When setting up homing turn off the hard limits so that they don't cause any issue and once you have homing and soft limits sorted then move onto the hard limits. You turn hard limits off under general settings.

If your homing switches are not at the extreme ends of travel and are inside the soft limit area then you cannot use hard limits as they will trip before you reach the end of travel.

Hope this helps

Regards

Peter
 

breezy

Arie
Staff member
Just press Prt Scr button.

MASSO then saves a numbered bitmap file (.BMP) to the USB stick.

Then upload as per instructions down below in the UPLOAD FILE section.

Regards,

Arie.
 

rroie

rroie
Could not get Prt Scr to work. I have a new monitor keyboard and mouse coming UPS today. Will try it again then

Thank You

Roie
 

rroie

rroie
Ok, got the new mouse, keyboard and monitor. Logitech MK240 NANO. Still can not Print Screen. Can not Home. Can not Jog/Rapid.
 

rroie

rroie
OK, got the print screen to work so here it is. I think it is a pulses per revolution problem. The soft limits work on the right side x axis but home always crashes. The machine coordinates are always way off.

I am used to Mach3 and UCCNC calibration that will set the steps or pulses per revolution.

Thank You

Roie
 

Attachments

  • Print-Screen-001.bmp
    769.1 KB · Views: 16

ecs

ECS
@rroie I've just gone through my setup a few weeks ago on my lathe so i will try and help where i can.

I'm assuming you have the machine jogging with the correct + & - going in the correct directions. Please check this before you start on the jog screen. Also check the limit switches are working on the F1 screen.

Now move the machine to the middle of its working area. Hit the home button and check to see which way it homes. You can press the escape key to stop the homing at any stage. If its going towards the limit switch great. If not you'll need to go to the F1 screen and go into the homing tab. Open this up and on the "direction invert" tick the axis which is going the wrong way. Hit save and now the axis should home in the correct direction.

Let me know how you go.
 

rroie

rroie
They all move in the right direction to home but will not stop. Limit switches go high when I put a piece of metal in front of them. I have changed the wizard zero position countless times with the same result crash. For instance in the wizard I set X axis to zero and move it to the other end 48 inches.(will not rapid jog) set calibration at 48 in wizard and save. Machine coordinates show 48. As soon as I hit home for X it goes to 70 and starts counting down. So it never gets to zero. I am now using the Homing Dialog Box to set homing sequence because what ever one I am homing is going to set off homing error and nothing is going to work. Get to cycle the power switch.

Thank You

Roie
 

Attachments

  • IMG_4122.JPG
    IMG_4122.JPG
    3.2 MB · Views: 12
  • IMG_4121.JPG
    IMG_4121.JPG
    3.4 MB · Views: 10
  • Print-Screen-001.bmp
    769.1 KB · Views: 20

ecs

ECS
@rroie where do you have the limit switches assigned to? Input or output? I can see an output showing high in the picture but nothing assigned to it.

Can you take a picture of the F1 screen showing all the inputs and outputs.
 

rroie

rroie
The inputs are just what they say MPG and XYZ. Number 10 output is water pump cooling fans for water cooled spindle.
 

Attachments

  • Print-Screen-002.bmp
    769.1 KB · Views: 17

evermech

evermech
Hi @rroie

not sure if this is relevant but I had to slow my homing speed down because the inertia of the axis just went right over the prox. Could be a combination of the speed and the accel/decel ramps setting.

What are the mechanical details about your drive?

pulses per rev of motor

any gear box and if so what's ratio

pulley on motor how many teeth

pulley on ball screw how many teeth

pitch of ball screw

could help with getting set up correctly

Guy
 

rroie

rroie
This thing is slow rapid does not work. No pulleys or gears. 20 mm ball screws for X and Y axis. 16 mm ball screw Z axis. Both 16 and 20 mm ball screws 1 turn = 5 mm. Stepper Motor drives set for 1600 pulses per rev. 5 threads per 25 mm. Not sure about pulses thing Mach3 and UCCNC would do the calibration for me. Masso set for inches. I sure appreciate the help.

Thank You

Roie
 

evermech

evermech
I do believe you can change to metric in the general settings. I don't have a Masso in front of me to check.

If you can find the setting for metric change it then post another pic of the axis setup page please
 

evermech

evermech
Ok can change distance to 5mm and max feed to 5000 for now.

Then reboot and jog machine to several inches away from X axis home prox. Go to settings homing page and ask it to only home X axis. Try to home just that 1 axis and see what it does.

Could be an idea to make sure that the prox for,X axis is about 1/16" or so away from target.
 

rroie

rroie
Jog is a lot faster but takes a while to stop. Makes me nervous. But Homing crashed as usual.

Thank You

Roie
 

Attachments

  • Print-Screen-004.bmp
    769.1 KB · Views: 19
Top