Backup Battery Fail?

angelars

AngelArs
Hi I just installed the new software (in brand new unit) and when I booted up the screen said "Backup Battery Fail".

I figured I had the battery in upside down, so I reversed it. Same exact error.

Does this mean that even though it's a brand new unit, that a dead battery was shipped to me?

I tried to find documentation on the website regarding the battery, but I couldn't find anything.

Could you post the link for the documentation on how to fix this please? Thanks.
 

breezy

Arie
Staff member
Quote from AngelArs on September 18, 2018, 3:27 am

Hi I just installed the new software (in brand new unit) and when I booted up the screen said "Backup Battery Fail".

Last comment in all the v3.3x release notes since MASSO CORE UPDATE V1.26

  • You might see a Backup battery fail detected alarm, please DO NOT remove the battery on the controller and simply power cycle the controller and the message will automatically go away.

Arie.
 

masso-support

MASSO Support
Staff member
if the battery is installed then you should only see the message only once and as per the documentation a simple power cycle should clear the alarm.

@angelars whats you controller serial number?

Can you share some photos of how you have the battery installed.
 

angelars

AngelArs
The battery is installed as per the instructions noted in the link I posted above.

It is working fine now.

I am going to get the touchscreen update and test the new monitor next...
 

angelars

AngelArs
The problem was that when I was reading the set-up documentation and following it step by step, there was no information pertaining to the battery, or the error message.

It was only when I did a manual search on the term 'battery' that the information finally came up.
 

routertrav

routertrav
Just FYI, I had this same issue last week. I have a thread here about it. I installed battery and got the battery backup fail window. I powered the Masso on and off at least 5 times, trying to get the message to go away. I decided to just power off, with battery installed, for a while. I want to say it was for about 30min or so. Power on, and all was good. Week later, and everything is still good to go.
 
Top