File milling magic circles !

maciassimon

maciassimon
I have regular problems reading files in MASSO ...



Circular milling pattern appear on the file, and they are really cut !



Imagine my face the first time I tested if it's just a graphical glitch ... ;)





I make my file with Cambam, and there are no circles when I simulate my .nc with Camotics...



So there are two problems: these circles, and the fact that MASSO does not warn me that cutting exceeds the size of my CNC table!

Masso should check that the gcode launched does not exceed the size of my table...


I join my gcode file, a screenshot and my settings ...
 

Attachments

  • Print-Screen-001.bmp
    3 MB · Views: 16
  • plaque2.1.nc
    414.9 KB · Views: 17
  • MASSO_Settings.htg
    620 bytes · Views: 15

jolbas

Jolbas
I had similar problems when arcs are more than 90 . Some applications don't like that. In sheetCAM I can choose to split arcs over 90 . Maybe you have a similar setting in Cambam.

Try to make the smallest file possible where problem remains.
 

maciassimon

maciassimon
It seems to be a problem of interpretation of codes I and J ...
I have no problem simulating, but only with masso ...
I will try to reproduce the bug, and see which line generates it, but it's not easy!

In any case, it's not a matter of file import (Masso link or USB) because I tried at least 15 times to put the same file, and the circles appear in the same place every time!

I join a photo of my messed plate, one of the masso screen, and one of the simulation on camotics.

Thank you for your help ! ;)
 

Attachments

  • cercle-ecran.jpg
    cercle-ecran.jpg
    126.6 KB · Views: 14
  • cercle-camotics.jpg
    cercle-camotics.jpg
    132.2 KB · Views: 13
  • cercle-plaque.jpg
    cercle-plaque.jpg
    141.7 KB · Views: 13

jolbas

Jolbas
I try to zoom in and enhance your image but I can't read the code on line 96 in plaque1.2.nc.

Is the screen shot from when it is stopped during milling the big erroneous circle?

Try if the fault remains if you remove all lines but i.e. line 90 to 100 in a text editor
 

masso-support

MASSO Support
Staff member
its not an issue with the file or if you send via MASSO link or directly copy to USB. There is some issue with the arc gcodes, will have to have a good look.

what post processor are you using?
 

jtknives

JTknives
This is exzactly what mine was doing when I posted the question about G03 and G02. I did a simple test program and removed the I and J and just used R and the magic circles went away. I think there is somthing in the programming that does not like G2 and G3 codes that use I & J.
 

maciassimon

maciassimon
Quote from MASSO Support on February 15, 2019, 12:15 am

@maciassimon so did you machines this file? and did it machine ok?

Yes, I machined this file, and it machined the circle, as we can see in the photo


Quote from JTknives on February 15, 2019, 9:42 am

This is exzactly what mine was doing when I posted the question about G03 and G02. I did a simple test program and removed the I and J and just used R and the magic circles went away. I think there is somthing in the programming that does not like G2 and G3 codes that use I & J.

I'll do the test when I have a little more time trying to isolate the line that generates the circle ! ;)

Thanks for your help ! ;)
 

Attachments

  • cercle-plaque.jpg
    cercle-plaque.jpg
    141.7 KB · Views: 11

masso-support

MASSO Support
Staff member
Hi maciassimon

I'm not really sure what the cause of the circles are but I loaded the plaque2.1 file into Mach3 and you will see that it has the same issue as you are seeing on the Masso.

What Post processor are you using to generate your Gcode?

I would try the Mach3 Post processor if you aren't already and see if that fixes your problem.

It has been many years since I used CamBam myself and I would have to reload and have a play to remember how to use it to be honest.

I also vaguely recall there are settings for circles in CamBam with a choice between incremental and absolute.

Cheers

Peter
 

Attachments

  • Mach3.jpg
    Mach3.jpg
    33.6 KB · Views: 17

jolbas

Jolbas
I m going to try this tomorrow because I had the same issue with g-code from sheetcam. When I load plaque2.1 into Sheetcam there is no big circles.

What would be nice is that Masso refuses to start the cycle if movements in file somewhere goes outside machine limits. Masso obviously finds the outer limits of the files g-code when drawing the file on screen so that could be a good point in your source code to catch this problem.

Regards

/Bj rn
 

testyourdesign

testyourdesign
@maciassimon and @jolbas

This is a common problem that occurs with some post processors. Not all post processors are the same. Take a look at how they process G02 and G03 to see if it uses the same information as Masso posted for their Post Processor Requirements. There are two ways of programming G02 and G03 so its likely that the post processor is spitting out the wrong one for those lines of code. Mach3 allows you to use either one of the methods depending on its software configuration settings so not all flavors of the Mach3 post will work with Masso. Check out this site for details on how to program G02 and G03.

Its a good idea to learn the details of how to program in G-Code instead of simply relying on the post processors. You'd be amazed to see how much you can do with just a few lines of G-Code. In many cases its faster to program it directly.

Cheers, Stephen Brown
 

jolbas

Jolbas
Now I've tested and it has to do with a rounding issue. If the movement in G2 or G3 is smaller than 0.001 Masso sometimes round X and Y to be the same as the last position. This results in Masso believing it's a full circle. The solution for now might be to tell the CAM program to not make this short arcs. Sheetcam is configurable to do straight lines instead under a certain limit.

This code should do a very short almost straight line but results in a very big full circle

G0 X0 Y0
G2 X0.0004 Y0 I0.0002 J-1000
 

testyourdesign

testyourdesign
@jolbas

Thats a good point to remember. I usually set my minimum cutting radius to .010 inches under the Passes Tab in Fusion 360 CAM to avoid this issue. The default settings in the post processor are also set to that value but I don't think you can adjust it as easily in SheetCam or V-Carve Pro.

Thanks, Stephen Brown
 

Attachments

  • Fusion-360-Defaul-Post-Settings-for-Masso.JPG
    Fusion-360-Defaul-Post-Settings-for-Masso.JPG
    68 KB · Views: 12
  • Fusion-360-Defaul-Passes-Tab.JPG
    Fusion-360-Defaul-Passes-Tab.JPG
    31.5 KB · Views: 11

jolbas

Jolbas
@testyourdesign

Isn't it the "minimum chord length" setting that need to be at least 0.001. You have set it to 0.25 which should be ok.

And you are right, it's not that easy to adjust in SheetCAM. You have to edit the post processor script and in the OnInit() function add or adjust this line:
minArcSize = 0.2 --arcs shorter than this are converted to straight lines​

I have it set to 0.2 mm. I can't imagine a plasma cut where a shorter arc than this would differ from a straight line.

I don't have CamBam which I think @maciassimon have but according to this post there is a post processor setting called "Minimum Arc Length"
 
Top