Home or Limit Switches Not working

adstaggs

adstaggs
Version I am using release v3.42

I am using 3 mechanical limit switch X,Y, and Z -NC

+ Power is connected to each Common on the switch

X is on Input 20

Y is on Input 21

Z is on Input 22

It shows H when triggered, L is normal

But when jogging and the switch is triggered nothing happens but the F1 show High

Not sure what is the issue.
 

adstaggs

adstaggs
Yes per documentation.

I thought for just testing you only needed the Homing Sensors Inputs like I have 20-22 for x.y.and z, so when ever I manual trigger it should stop the axis from moving?
 

masso-support

MASSO Support
Staff member
Hi adstags

If you want the switches to stop your machine when jogging you need to go into General settings on the F1 Screen and remove the check from "Disable Hard Limits" then when you trigger a switch it will stop the axis.

You are however better off using them as Homing switches and use Soft limits to control your Axis movement. Use the Hard limits as a last resort.

Cheers

Peter
 

adstaggs

adstaggs
I unchecked the Hard Limits and now when I trigger the switch it show for axis X Hard Limit Alarm , same for Y and Z .
 

adstaggs

adstaggs
OK so if I understand with Hard Limit Disable unchecked it should give me the alarm, yes I will go with Homing and soft limits.

Thanks.
 
Top