home swicth and limit

madi

madi
hi, did someone know why my axis not stop when they hit the switch on jog mode? ive just finish install the switch, when homing is ok, the problem is jog.
 

testyourdesign

testyourdesign
@madi You might have forgotten to set the soft limits in axis calibration. Take a look at Travel Minimum and Travel Maximum.
 

Attachments

  • X-axis-settings-mm.png
    X-axis-settings-mm.png
    3 KB · Views: 13

madi

madi
thanks bro,, that mean the switch cannot overwrite the soft limit? I thought the switch will protect the axis from over travel if something happen,,before I put the switch , I just relay on soft limit as the picture u upload, until ive got update the system,, it seem don't read the limit that I have set, that y I decide to put the switch,, that coast me one unit the controller when I accidently make wrong connection..
 

testyourdesign

testyourdesign
Basically once you establish the Home position Masso will use the minimum travel and maximum travel setting for its travel limits. I don't think it can use limit switches since I don't see a configurable input for limit switches in the inputs list.

 

tayloredtech

TayloredTech
It could be an option (until limit sensor inputs are implemented) to wire some limit switches in series and into the E-stop input just to save the machine hammering into the end of the rails etc.
 

masso-support

MASSO Support
Staff member
@madi you can wire two switches on both sides of the axis, if used in Normally Open then in parallel, if used in Normally Closed then in series. Then connect it to the homing input of the axis, goto general settings in F1-Setup screen and make sure hard limits are not disabled. Now once the machine is homed if either of the switch is hit then the system will stop motion and go into hard limit alarm.
 

tayloredtech

TayloredTech
Quote from MASSO - Support on August 30, 2018, 1:12 am

@madi you can wire two switches on both sides of the axis, if used in Normally Open then in parallel, if used in Normally Closed then in series. Then connect it to the homing input of the axis, goto general settings in F1-Setup screen and make sure hard limits are not disabled. Now once the machine is homed if either of the switch is hit then the system will stop motion and go into hard limit alarm.

Would that stop the machine from going past the limits in jog mode? @madi said it is fine homing but not when jogging the machine?
 

madi

madi
thanks for the info guys,,i will try to do that.. on the f1 screen , if i using normaly close swicth,, which one do i need to set the signal, low or high? sorry guys for the bunch of question,, i am a new in this thanks
 
Top