Homing fails

vps

vps
I have a problem with homing and jogging my Masso G3

When I hit ctrl-alt-home I almost every time I have to do this three times and reboot before it is set

After I run a g-code, sometimes the Y-axis run to max or min when I hit the shift-arrow-key and the program locks and I have to reboot.

I changed feedrate from 400mm to 50mm/min and keyboards wired and wireless, switched off hard limits, but there is no solution
 

cncnutz

CNCnutz
Staff member
Hi @vps

Can you please be a bit more specific?

When you start homing what exactly happens that requires you to reboot? Are you getting an alarm and if so what does it say?

Can you please share screen dumps of the General settings, homing, X, Y and Z axis setup pages? You can save a screen print by pressing the print screen button on your keyboard or by pressing CTRL+P.

This will put image files on the USB stick which you can upload for us to look at.

Cheers

Peter
 

vps

vps
Hi Peter,

Thank you for you quick response.

I made video's with my gopro , if you like i can send them to you by wetransfer

Maybe you can send me a direct email?

Ren
 

cncnutz

CNCnutz
Staff member
Hi @vps

If you send an email to Masso support using the link at the top of the page and just put a note in it of video for Peter and maybe a link for this page. I will pick it up this evening when I get home from work and have a look.

You can also upload it to Youtube or post the Wetransfer link here if you like. I leave it to you to decide.

Cheers

Peter
 

cncnutz

CNCnutz
Staff member
Thanks Ren

I have now watched the videos and here is a summary of it:

Your current software version is 3.42.2 and you are using the G3.

You start homing and the Z axis travels to the top, trips the Z axis sensor then stops, it doesn't back off the sensor and the machine stops still saying it is homing.

You restart and home the 2nd time the Z homes, backs off the sensor then the X & Y axis home together with each stopping when they reach their sensor but neither backs off and the machine says it is homing.

You restart a 3rd time and this time all 3 axis home and back off their sensors as expected.

I can see on the 2nd video that the Y- button is greyed out for some reason and the machine is not moving in jog mode.



We need to look at your settings next.

Can you please share screen dumps of the General settings, Inputs you have configured, homing, X, Y and Z axis setup pages? You can save a screen print by pressing the print screen button on your keyboard or by pressing CTRL+P.

This will put image files on the USB stick which you can upload them here for us to look at. Just beware there is a file size limit and a limit of 5 files per reply but you can zip them up into one file and it will easily be small enough.

Cheers

Peter

(#15935)
 

vps

vps
Hi Peter,



Thanks again for your response.

I uploaded the screenshots as you asked.

Extra info,I think the error is always short after manual zeroing the z-axis

Thanks,

Ren
 

Attachments

  • Print-Screen-Masso.zip
    217.1 KB · Views: 19

cncnutz

CNCnutz
Staff member
Thanks for the Screen Prints Ren

I looked at them last night and was none the wiser as to why it is behaving like it is. It might be obvious but I'm just not seeing it.

I am in the process of making a video on setting up homing an Masso which I hope to have out this weekend. I'm hoping it will help you and others in the future with setting up homing.

Cheers

Peter
 

vps

vps
Thank you Peter,



One question: Do you switch + or - with the proximity switches.

And do you no if all input ports equal for proxomity switch input.

In my case port 1 to 7 did not react on the switches.

Ren
 

cncnutz

CNCnutz
Staff member
Hi @vps

It depends on what type of homing switch you are using and how you wire it.

Can you let us know what switch you are using and how you have it wired?

Cheers

Peter
 

vps

vps
12 volt
 

Attachments

  • Proximity1.jpeg
    Proximity1.jpeg
    85.6 KB · Views: 14
  • Proximity2.jpeg
    Proximity2.jpeg
    85.6 KB · Views: 11

cncnutz

CNCnutz
Staff member
Thanks @vps

From what I can see of the sensor the output goes high when it is triggered so should work a treat when you connect it to an input.

The output should go +ve with respect to Masso ground when you trigger the sensor. You should be able to test it with a volt meter.

Connect the sensor to + & - power supply and measure the following 4 senario's

Output to -

Output to +

Now trigger the sensor with some metal and measure

Output to -

Output to +

This will tell us exactly how the sensor behaves and then we can wire it.

You can test the inputs on masso by simply pulling up the F1 screen and applying +ve from Masso PSU to each input. You will see them all change from low to high.

Cheers

Peter
 

cncnutz

CNCnutz
Staff member
Hi @vps

I have been planning to write a document to identify homing sensors and show how to connect them for some time now.

I think I have come up with the best way of doing it and have attached a copy for you to try.

I'm hoping this will help with the connection and configuration of various sensor types. See if it helps with your setup and if you find anything wrong please let me know in case of an error or if your sensor matrix doesn't appear on the table.

hope this helps

Cheers

Peter
 

Attachments

  • Identifing-homing-sensors-and-how-to-wire-them.pdf
    233.4 KB · Views: 17

cncnutz

CNCnutz
Staff member
Hi @vps

The NPN sensors that only go low when triggered but don't go high when idle are the problem.

Masso only sees an input when the input sees a voltage so a resistor is added between Masso +ve and the input to take it high and the sensor will pull it low when it triggers. This is why this type of sensor needs to have the input inverted. I'm lucky that my NPN sensors don't need the pull up resistor.

Cheers

Peter
 

masso-support

MASSO Support
Staff member
Hi @vps

When you get a chance could you post your Masso serial number here. We found a software issue that might help with your homing problem, though it is not homing switch related, which you appear to be looking into at the moment.

Cheers

Peter
 

vps

vps
Hi Peter,

I think that I found what the homing problem causes. When WiFi is switched off, homing is no problem.

When I switch WiFi back on, I have the homing problem.

Ren
 

masso-support

MASSO Support
Staff member
@vps

Hi Ren

You should have received some new software to try out with your homing issue. Have you tried it yet? If so do you still have the issue after updating?

With regards the WiFi could you elaborate please. Are you using the My Masso setup direct to your PC or are you connecting it via network?

I assume to turn it off you simply hit the disconnect button. Did you have the PC connected via WiFi at the time or was it connected to the network but the PC not connected to Masso?

Cheers

Peter
 

vps

vps
Hi Peter,

I installed the new software G3-5814 Mill 5 axis v3.42.4

The issue is still pressent after the software update

I use the Masso in a WiFi network ip DHCP prefered adres 192.168.2.15

The pc was WiFi connected when I swicth on/off by pressing connect/disconnect on the Masso

Ren
 
Top