Homing

mr-ben

Mr. Ben
I have masso input pins 1,2,3 configured as input homing. The X and Y work ok, hitting the sw and pull back. The Z, which is last, hits the sw, stops, and gives a hard limit alarm. I can't clear the alarm without rebooting.

Any ideas? I've checked configuration and looks same as X and Y.

Ben
 

masso-support

MASSO Support
Staff member
whats your homing feedrate? have you tried reducing the homing feedrate?

Also please check that your Z axis homing input in F1 screen only shows H when the switch is pressed, else select the input and press space key to invert it. If the Input shows H when the switch is not pressed then you will have issues with homing.
 

mr-ben

Mr. Ben
Hi,

I have tried several feed rates, from 500MM/M to 100MM/M. If I watch F1 during homing, I see L during homing, and that goes H when it hits the sw. Should I try another input? Where does the hard limit alarm come from? When the Z axis hits the sw and the status light goes H, why does it say hard limit alarm AND blink the homing sw? Why both? How do you set a HARD LIMIT?

Ben

Also, you might want to check your wire NUMBERS for step and direction for clear path servos.
 

masso-support

MASSO Support
Staff member
Have you tried to disable hard limits in F1-Setup under General Settings? does homing works fine after disabling hard limits?

Regarding the clearpath did you find anything wrong with the numbers?
 

masso-support

MASSO Support
Staff member
@mr-ben I was just discussing the issue and am told that there has been a bug found regarding hard limits, can you please let us know your controller serial number and will email you the test software.
 

mr-ben

Mr. Ben
I tried disabling hard limits and all it did was clear the alarm, Z still stops after hitting the sw, status goes H. Low feed rate makes no difference.

About the servos: I had to use 2 and 6 for step and 3 and 7 for direction. I believe your docs say 3 and 7 for step and 2 and 6 for direction.

I'm going to load 3.35 and see if that helps.

Thanks for the support, we will get this solved.

Ben
 

masso-support

MASSO Support
Staff member
yes you are right @mr-ben, after checking we found that the numbers are swapped, thank you so much for pointing the issue and we have now updated the web page with a new wiring example.
 

mr-ben

Mr. Ben
I found my homing problem, I had entered wrong values for min and max travel. Rookie mistake! All OK now. Thanks for your help.

Ben
 

lordy

lordy
Hi I'm running V3.36 and having the same issue as above. I have tried everything listed in the posts but my Z axis is still hitting the limit switch and not backing off, then giving a Z hard limit alarm?
 

mr-ben

Mr. Ben
Lordy...

Here is what I did to clear the same problem: Go to F1, and set Z max travel to 0.000mm, set Z min travel to -200.000mm ( or what ever your Z travel is).

Worked for me.

Ben
 

lordy

lordy
Hi,

I think Mr Ben has highlighted the problem I put the Z maximum value as a positive (but it is homing at the top of the axis) rookie mistake, I have not tried it yet but I think that is the problem.



Thanks All.
 
Top