I'm doing something silly with auto tool setter

parkin

Parkin
Hi, Im doing the first setup with the auto tool changer and multiple tools in a file, and I obviously have a setting wrong.

The masso homes correctly and uses the auto tool setter to home Z height, so thats all fine.

file runs fine, forthe first tool (10) then calls tool change, from tool 10 to tool 11 (chamfer mill) which is fine. after i change tool it goes and uses the toolsetter to check the height (great)

Except it is not right, the tool ends up about 12 mm higher than it should be and starts cutting air from that point on?



attached is the clamp i'm trying to make and the file for it.



any help form someone smarter than me would be greatly appreciated !
 

breezy

Arie
Staff member
@parkin

Attach gCode that you are running, so that we can check if it is a ATZ problem or a coding error.

Regards,

Arie.
 

parkin

Parkin
sorry- I thought I had- here it is.



thinking it through further and after some reading through other posts here, , i believe its a mistake im making with how to use work offsets.



what i had done is set the top of the first tool on the correct Z 0 position and then pressed the 'Z Zero' button on the screen. This obviously is not right- i should be creating different work offset when coding up the job, and Zeroing that on the masso controller before starting I guess?
 

Attachments

  • topface.nc_.nc
    70.3 KB · Views: 12

cncnutz

CNCnutz
Staff member
Hi Parkin,

The most likely cause of the tool length error on the 2nd tool change is you have homed your machine and then changed the tool. Don't ask me how I know this but it drove me crazy trying to figure it out until I realized what I was doing wrong.

You can change the tool before you home the machine or when Masso instructs you to change it but if you home and then change it, you will be right for the first cut and wrong for every tool change thereafter.

When you think about it you home the machine and it measures the tool length. You then change the tool and alter the length. You zero the tool and set 0 so it will cut properly but the next tool change will use the offset and original tool length to set every other tool.

This is how it should work for you.


Hope this helps

Cheers

Peter
 

parkin

Parkin
I'm still not winning with this at all.

There is a work offset G54 setup for the vice bench. this is setup and working fine.

i load the attached file, and say go to work origin- it moves to the correct point.

when then start- it moves off towards the router bed origin and hits the soft X axis limit.

im sure this is all setup correctly.

post is out of fusion, using the most recent masso cps file. G54 is selected as the work origin in the setup in fusion setup.



what am i missing here??
 

peter35

Peter35
having similar issues with the mill.

Home machine and set first tool, runs second tool and heights are wrong, Machine does home z axis before moving to tool change, l will confirm this when l next run machine.

Am using a dewtronics probe as tool zero, would be good if this was not affected by atc. i.i.e tool zero not set by atc.
 

cncnutz

CNCnutz
Staff member
Hi @peter35

It is absolutely critical that you either change the tool before you home the machine and then set your Z zero height or stick with the tool you homed the machine with and only change the tool when instructed when you run the program. If you don't the 2nd and every tool change after that will be wrong. When you home the machine and it does the auto tool measure and uses that measurement as the offset for all future tool changes. If you change the tool and alter it's height then you upset the offset so the 2nd and subsequent tool heights will be wrong because the offset is wrong. If I decide I want to change the tool after homing the machine I will home the machine again and then set my Z height. That way I have no problem.

It took me a little while to work out what I was doing wrong.

Cheers

Peter
 

cncnutz

CNCnutz
Staff member
Hi @parkin

Did you attach a file or are you refering to the one a few posts above yours.

Is hard to tell with soft limits as it is dependent on your machine setup, where you place the work etc.

If you referring to the Topface.nc file it's even harder because it is all circles so the X value is probably not the value but where the arc travels too that is the problem.

Cheers

Peter
 

breezy

Arie
Staff member
@peter35, @parkin

I'm using a Drewtronics and ATZ with no problems. The secret is to connect "ground" / -ve lead to the probe tip when you home the mill with the Drewtronics and ATZ (ATZ requires "grounded" tool to trigger, the Drewtronics tip is isolated from the spindle, don't connect power to the Drewtronics while you do this). Now when you zero the Z axis with the probing routine, your heights are correct. If you want to save that Z height in G54, you need to move the probe down to zero, issue a G92.1 in MDI to clear the temp offset (if you don't do this, things go wrong) then in the G54 settings dialog click on the Z axis set button. Now when you change a tool using ATZ the MASSO will adjust its internal offset to compensate for different tool lengths.

Use similar steps if you want to set the X&Y in G54.

The Fusion post processor issues Z home as part of the tool change function coding, this is a sample.

N465 G28 G91 Z0.
N470 G90
N475 M5
N480 M1
N485 T30 M6

Regards,

Arie.
 

parkin

Parkin
Sorry I thought I had attached the file, but for some reason it did not attach.



so to put it all together in one post so its easier to understand:



I have a file modelled in Fusion 360. Machine WCS offset is set as 55

G55 offset is set as the vice corner in the masso controller.



1 I home the machine

2 I load the file,

3 click 'go to work origin', it moves to the correct place.

when i start the file, it moves off towards machine 0,0 and hits the soft limits.

the first lines of the .nc file are

(1001)
(MACHINE)
( VENDOR VERTICO CNC)
( MODEL BIG RED)
( DESCRIPTION AEC ROUTER)
(T10 D=6. CR=0. - ZMIN=-9. - FLAT END MILL)
N10 G90 G94 G91.1 G40 G49 G17
N15 G21
N20 G28 G91 Z0.
N25 G90

(2D ADAPTIVE1)
N30 M5
N35 T10 M6
N40 S11061 M3
N45 G59 P55
N50 M11
N55 G0 A0............................
 

parkin

Parkin
heres a screenshot of the work offset in fusion
 

Attachments

  • Untitled.jpg
    Untitled.jpg
    325.1 KB · Views: 11

testyourdesign

testyourdesign
@parkin

The G28 at the start of your program makes it go to machine origin. That looks normal but for some reason, you used G59 on line N45 instead of G55. Change N45 to read G55 and it should work.

Cheers, Stephen Brown
 

parkin

Parkin
thanks Steven,

the thing that has me puzzled is where the G59 is coming from. is the post processor on fusion 360 causing this?

i really not want to have to manually modify gcode files every toolchange
 

testyourdesign

testyourdesign
There might be a problem with the post-processor you used to create the code. Try setting a different offset number in Fusion to see what happens. Is this a custom post-processor or the standard one that came from AutoDesk?

Peter and Arie are very familiar with edits to the Post Processor. I'm sure they will chime in soon.

Cheers, Stephen Brown
 

parkin

Parkin
thanks- I think you are onto it!

it appears that changing the WCS origin number in fusion makes no different to the generated g code.



So how do other people use the work offsets in the masso controller?



I'm using the standard Masso CPS off the autodesk site ----



/**
Copyright (C) 2012-2019 by Autodesk, Inc.
All rights reserved.

MASSO post processor configuration.

$Revision: 42473 905303e8374380273c82d214b32b7e80091ba92e $
$Date: 2019-09-04 07:46:02 $

FORKID {C601E17B-ED65-4897-AC13-EE84621953F2}
*/

description = "MASSO";
vendor = "Hind Technology Australia";
vendorUrl = "https://www.masso.com.au";
legal = "Copyright (C) 2012-2019 by Autodesk, Inc.";
certificationLevel = 2;
minimumRevision = 40783;
 

breezy

Arie
Staff member
Quote from Parkin on November 12, 2019, 3:28 am

thanks- I think you are onto it!

it appears that changing the WCS origin number in fusion makes no different to the generated g code.

So how do other people use the work offsets in the masso controller?

In Fusion when you do the setup the last tab is used to change which WCS is to be used.

0 & 1 is G54

2 is G55

3 is G56

etc to G59

In topic Fusion manual NC commands in post #4 is is a post processor that I modified to allow passthrough commands to be entered in Fusion, also changed the formatting of some sections of the gCode functions.

Regards,

Arie.
 

parkin

Parkin
Fantastic- thank you, that will be exactly what it is, I assumed they would relate to gcode offsets.

i assume I don t need to update the post processor to your one to make that work?

Thanks

for your help
 

breezy

Arie
Staff member
@parkin

I hadn't read your earlier post (#11 when answering in #17) about using G59 P55. When you use G59 Pxxx you are telling the controller to use offset number xxx as MASSO only has 6 WCS, P55 is nonexistent so it reverts to the default G54. This should have shown up in the status bar on the bottom of the screen.

As I said in post #17 if you wish to use any offset other than default you need to enter a number from 2 to 6.
Quote from Parkin on November 12, 2019, 2:19 am

I have a file modelled in Fusion 360. Machine WCS offset is set as 55

G55 offset is set as the vice corner in the masso controller.

I'm assuming from this comment that you entered 55 into the WCS offset in Fusion, so when you generated the gCode Fusion created G59 P55 as the WCS.
Quote from Parkin on November 12, 2019, 6:39 am

i assume I don t need to update the post processor to your one to make that work?

No you don't need to use my modified post but if you want to have the various groups of code formatted to be together instead of split up. Using your example code.

N10 G90 G94 G91.1 G40 G49 G17
N15 G21
N20 G28 G91 Z0.
N25 G90

(2D ADAPTIVE1)
N30 M5
N35 T10 M6
N40 S11061 M3
N45 G59 P55..........

Codes G40 to G49 are not used by MASSO so are not needed.

Lines N20,N25 are part of the tool change command group.

The comment (2D ADAPTIVE) is part of the start of section group

So just moving the comment call to the beginning of the section group before the home call results in the code looking like this

N10 G90 G94 G91.1 G17
N15 G21

(2D ADAPTIVE1)

N20 G28 G91 Z0.
N25 G90
N30 M5
N35 T10 M6
N40 S11061 M3
N45 G59 P55 ......

Now the relivate code is grouped together.

Regards,

Arie.
 

cncnutz

CNCnutz
Staff member
Hi @parkin

If you are getting a soft limit when you do a G28 it will be because you have the home position Machine X0,Y0 outside of the working envelope set by your soft limits.

If you share screen prints of your X,Y and Homing screens we will probably be able to confirm it for you.

To do a screen print press CTRL+P and a copy of the screen will be put on the USB stick that you can post here.

Cheers

Peter
 
Top