Invertek Optidrive ip20

bictonmensshed

BictonMensShed
Trying to fire up a Optidrive IP20.

Have wired it as per 3DTEK diagram https://3dtek.xyz/pages/masso-wiring-diagrams

And as per Invertek manual https://inverterdrive.com/file/Invertek-Optidrive-E3-Manual

Digital input 1 operates with positive logic with the following input voltage range
  • "1" --- 8v to 30v
  • "0" --- 0v to 4v

Issuing a M3 - CW rotation or M5 stop makes no difference to the input voltage to Digital input 1.

The voltage on DI1 is 13.7v with respect to MASSO -ve all the time.

Regards,

Arie.
 

Attachments

  • Capture.PNG
    Capture.PNG
    64.4 KB · Views: 16

breezy

Arie
Staff member
OK I've been following @taylortech on Multicam S2412 CNC and I suspect that the cause of my problem is that the wiring diagram from 3DTEK has terminals 4 & 5 reversed. ie It has 24+ve on 4 instead of 5.

Screen_Shot_2017-11-01_at_4.57.54_pm.png


When I go to the shed again I will reverse those two leads and see if that fixes it.

Regards,

Arie.

For the Bicton Men's Shed.
 

masso-support

MASSO Support
Staff member
yes that could be the reason because current will only flow in on direction through the optocoupler transistor.
 

bictonmensshed

BictonMensShed
EDIT - Problem solved.

OK. I've fixed the enable wiring, 3DTEK's drawing is incorrect, swapped 4 & 5 and now the VFD is outputting a voltage but the spindle is not turning.

Measured voltages, first with the spindle connected and second with spindle disconnected. VFD is set to generate 50 hz for my multi-meter's AC range.

With respect to ground
  • U - 200 190
  • V - 145 190
  • W - 145 190

Between
  • U-V - 44 115
  • U-W - 42 90
  • V-W - 26 115

Measured resistance across all coils is 2 ohms.

So the question is which is faulty? Neither

Does anyone have suggestions? Had to set a parameter to use V/F mode.

Regards,

Arie.
 

breezy

Arie
Staff member
Quote from MASSO - Support on November 5, 2018, 7:49 pm

Have you set all the parameters on the VFD to take analog voltage input as control method?

Yes, I spoke to Ben at 3DTEK and we went through all the parameters that needed to be set, I had missed one of the advanced parameters.

He also said that the voltage differences that I measured was normal, when the VFD is not set correctly.

Regards,

Arie.

For the Bicton Men's Shed.
 
Top