Machine Coordinates Not Set to Zero in New Update

bjengle

bjengle
Hello,

Today I downloaded and uploaded the new software update eager to use my mouse and play around with its new functions. However for some reason the machine's coordinates are not set to zero, messing up the entire machine's limits and work volume. If someone could please help me I would greatly appreciate it. Maybe there is a button that sets all the axis for the machine coordinates to zero? And to be clear I am not talking about work coordinates I am talking about the machine coordinates that dictate limits and work volume. Thank you! I really enjoy the Masso!
 

Attachments

  • IMG_5526.jpg
    IMG_5526.jpg
    4 MB · Views: 14
  • IMG_5524.jpg
    IMG_5524.jpg
    2.3 MB · Views: 14

homebrew_cnc

homebrew_cnc
Same problem! I just crashed because it called a G53 G0 Z0 but my machine Z per the machine coordinates says it's -9.9999 so it slammed hard into the top stop. Simple work-around is to get the bad "home coordinates" we have now and set your axis limits to those.
 

homebrew_cnc

homebrew_cnc
okay, new problem. The masso froze on me, so I had to cycle power. I got a completely new set of machine coordinates. Z home was at -9.9999 before, now it's -22.4999. (the others are different as well, it's just Z is all I care about right now because I HAD it moving for a tool change position.) I tried putting G53 into MDI and resetting 0 via the shortcut keys, but that didn't work either.
 

homebrew_cnc

homebrew_cnc
Okay. I was able to get some help from an awesome guy. He said that in order to change those, you HAVE to do a homing routine, in which your Masso needs to receive inputs saying it's home-from home switches. In my case I didn't have them, so I made a manual switch. My servos have a home routine of their own but it doesn't feed back to the masso. I let them home, then I flip the switch and it tells the masso that the homing routine is complete and that resets those values. Hope that helps!
 

bjengle

bjengle
@homebrew_cnc

Over the weekend I did that exact thing! Luckily I had a proximity sensor laying around and wired it up to all three inputs on the masso for limit switches. I have clearpath servos which I use hard stop homing so I turned those off, ran the homing routine on the masso, tripped the switch 3 times and then boom I had all zeros for my machine coordinates! Then I did the hard stop homing routine after enabling my servos. Kind of a weird work around but I guess it works.

As for the Masso freezing I experienced that as well! I was running a guitar neck and had just changed out to a ball nose bit and the program ran for about 5 mins halfway and the masso and machine completely froze. I think the new update has a few bugs to be worked out still.
 

masso-support

MASSO Support
Staff member
sorry for the delay, somehow didn't see the notification about this new topic.
  • I think you guys are not using the homing option on MASSO to home the machine, is that correct?
  • In this new version MASSO powers up with the machine coordinates in the middle, because without homing the machine you can then jog the axis in both directions if required.
  • If you are not using the MASSO homing option because some of you might be using something like clearpath's hard limit homing option, this might be an issue.
  • If you are using clearpath's and dont want to use MASSO's homing logic then I think we should add and option in MASSO settings to skip MASSO homing logic, this way once you home the axis using clearpath hard stop, just press CTRL+ALT+HOME and MASSO will just set the machine coordinates to your required coordinates as per settings and not actually home the machine.
  • Please let us know your thoughts and we will have this added to the logic on priority.
 

bjengle

bjengle
Masso Support,

That would be so useful for the people who use hard stop homing that does not communicate with the masso like myself. If there was a key command or on screen button that allowed me to home the machine coordinates without it moving the motors that would be so helpful!

I think MACH 4 has something similar. You may want to make it an option in general settings to turn on and off the feature as most people may not use the feature. But, for us with servos like clearpath, it would be very helpful. Thank you for taking time looking into this and I am excited to see the new features in the next update. keep up the great work!
 

homebrew_cnc

homebrew_cnc
@masso-support ,

I agree with @bjengle that it would be a nice option. I personally would prefer an option in settings because I eventually want to get away from torquing on the frame of my machine constantly so I could turn it back to normal when I want. Either way would work though. Thank you for your constant positive support!
 

masso-support

MASSO Support
Staff member
thank you and will have this added to the next release, if everything goes by plan then it will be added in about a weeks time.
 
Top