Masso G3 MDI/gcode execution gets stuck, keyboard repeat problem, UI issues

shaun

Shaun
Hi,

I've just got my G3 not long ago and I'm having a play around with it on the bench while i get my control system all wired up.

I thought I'd try to do some very basic testing while I wait on parts to finish my CNC conversion and installation, and I need some help...

I've attached some pictures to help illustrate.

1. gcode either via the mdi input or generated by the internal conversational programming utility fails to execute.

I homed the machine, and can jog around with the onscreen controls and the MPG successfully.

In its most simplest form, if i enter "G0 X20" in the MDI box, the Masso appears to start executing but gets nowhere. The Job time counter starts incrementing and the percentage next to it remains stuck on 0%. I also cannot close the MDI box, hitting escape does nothing, I can't press any of the F1-6 keys without getting garbage in the MDI box, I can't use the mouse to click the F1-6 tabs at the bottom (button appears to click, but nothing changes on screen). I get the same behaviour when I load and cycle-start the gcode generated by the conversation programming wizard.



2. Keyboard repeat if I type faster than a single finger pecker.

I'm getting characters repeat in text/numeric entry boxes if i type at a normal pace (i touch type). If i slow down to a single finger pecker speed it seems ok though. I've tried different keyboards/mice (wired and wireless) - all behave exactly the same.

3. UI elements perhaps need some attention?

I've noticed that when a password prompt pops up, focus is not changed to the box and I have to (groan) use the mouse to put focus there to type the password in.

There are other oddities in the UI that aren't consistent with convention such as double clicking a word in a text/numeric field to select (to type over the entire word) does not work, click-drag highlighting to select a text region doesn't work etc. This forces you to use arrow keys to move the cursor and then backspace/delete characters before entering text.

In some places you can use the tab key to go to the next text entry field, but shift-tab doesn't take you back to the previous.

In the setup page, you are forced again to use the mouse to navigate many of the UI elements. It'd be great if you could tab between the columns, use arrow keys to select the item, enter in place of a mouse double click etc.

The above examples make things feel clunky, awkward and slow to use. Are there plans to update the UI to be more conforming to the usual ease-of-use conventions? It'd be great to be able to navigate around entirely without needing a mouse.



I know this probably seems like a lot in a single post, but its probably easier to deal with rather than splitting into multiple posts.
 

Attachments

  • IMG_1076.jpg
    IMG_1076.jpg
    124.9 KB · Views: 12
  • IMG_1077.jpg
    IMG_1077.jpg
    136.9 KB · Views: 10
  • IMG_1078.jpg
    IMG_1078.jpg
    221.4 KB · Views: 12

masso-support

MASSO Support
Staff member
have you entered calibration values for all axis in the F1 screen, if those values are incorrect and results in some mathematical calculation that will either zero or infinity then you will face issues.



regarding selecting text etc, those won't work, as to keep the design stable MASSO is not built on a PC based system and due to the resources being limited our core focus is to have a stable machine control design.
 

shaun

Shaun
Hi Masso,

Thanks for the help.

I had not configured the 4th axis on the machine. I'd configured XYZ and thought that would be enough considering the A axis was completely unconfigured and Gcode should only drive XYZ.

I put some dummy numbers into A and its working now.

Perhaps something to add to a future software version is a checkbox to disable an unused axis so it can be excluded from the motion planner's calculations?

My future intention with the A axis is to add a small rotary table/chuck.



I get you're not running a PC platform; I've done embedded systems development too. Stability or lack of a PC platform doesn't mean you need to avoid good UI design and widely accepted convention. From a software perspective there is some low-hanging fruit here that could be fixed that would really improve the user experience.

Specifically though, on the keyboard repeat issue, is this normal?



I'm not trying to be critical of your product - I think its great. I just want to make sure I'm getting the most out of it, and at the very least my experience is normal.

This controller is going on my mini-mill conversion, and my intention is to purchase a second controller+MPG to install on a big router I'm also building.

The mini-mill is an opportunity for me to gain earlier familiarity with Masso and use it to make some of the more intricate small parts I need for the big machine.



Cheers!

Shaun
 

masso-support

MASSO Support
Staff member
hi @shaun, not a problem and we appreciate your feedback, this is how we get to know what the clients want and will make things easier for them, we have added your feedback to our development list.
 

angelars

AngelArs
Quote from Shaun on October 8, 2019, 2:18 am

Perhaps something to add to a future software version is a checkbox to disable an unused axis so it can be excluded from the motion planner's calculations?

This is a really good (common sense) idea! Surprised it wasn't originally included.
 

greentimber

GreenTimber
Hello,

I've had the same identical issue with MDI and Gcode failing to run whilst getting a Masso G3 mill up and running. Fixed it now after finding this post. I'm from a non CNC background, so some mention in the documentation of how to handle unused axes would be great. (Perhaps make it more obvious if it already exists somewhere) :)
 

metzenovich

Metzenovich
I'm a new Masso user just finishing up a retrofit of a Gerber Sabre 408 and had this problem.

Here are 3 suggestions that would have helped (in the order it would have helped me most as a Masso novice):
  1. Rather than just not working, show a popup / warning, like "All axis must be configured before running G-Code or MDI will work".
  2. Have this mentioned in the documentation for configuring the axis.
  3. Have a way to disable an axis so it isn't used and doesn't cause this hang.

That being said, thanks to finding this quickly in the forum it wasn't a big deal. The configuration wizard made it really easy to setup my axis to get fairly accurate. I won't know just how accurate until I do some test cuts.
 

thomasvank

Thomasvank
I am also a new masso user, I just switched over from a parallel port breakout board and mach 3 on my RF-45 clone mill. I bought the controller with more axis's then I needed because I didn't know if I needed an A axis to run my tool changer which runs on a stepper motor for indexing. A disable axis box would be a great addition to the set up screen, or a fault display pop up would help (axis not configured).
 
Top