Newbie, can jog but will not run from file

carbon

Carbon
I have just built a CNC Plasma and have just done first set up and got all axis running and homing, I tried a simple cut file but none of the axis move.

In "Program & MDI" I tried "go to work origin" and nothing moves. The Masso seem to lock up and I have to switch off and back on.

I am not sure if I missed something in the set up.
 

masso-support

MASSO Support
Staff member
Hi @carbon

What do you see on the screen when you start your program, are there any alarms for example?

What software version are you running?

What is your Masso serial number?

When you are in MDI and enter a command like G0 X100 does the X axis move 100mm?

Can you share the Gcode file that will not run?

Cheers

Peter
 

carbon

Carbon
It seems to run code then stops where it is going to move. G00

no errors, it seems to lock up and do nothing.

serial number G3-5888 software 3.42.2

I am not sure if it is feed speed related, I have tried changing feed rates and setting maximum feed rate but nothing seems to change what happens.
 

Attachments

  • IMG_4692.jpg
    IMG_4692.jpg
    83.5 KB · Views: 15

masso-support

MASSO Support
Staff member
Thanks @carbon

Could you send a screen print of your X & Y axis settings please. I need to check the settings there please.

To save a copy of the screen to the USB flash drive just press CTRL+P and it will copy the screen. Then you can email the screen prints

Cheers

Peter
 

carbon

Carbon
I tried the screen capture but the file is unreadable
 

Attachments

  • IMG_4693.jpg
    IMG_4693.jpg
    75.1 KB · Views: 11
  • IMG_4694.jpg
    IMG_4694.jpg
    79.1 KB · Views: 13
  • Print-Screen-001.bmp
    400 KB · Views: 12

breezy

Arie
Staff member
@carbon

So your motors are able to move the plasma head the full distance of it's travel in just 6.5 & 8.5 rotations?

When you jog the machine does the DRO match the distance travelled?

I think you have a decimal point in the wrong place in the Motor: distance per revolution. Did you use the wizard to set it?

Regards,

Arie.
 

carbon

Carbon
I did use wizard to set it up,

It jogs by the keyboard full travel, and homes without an issue but stalls at the line in the G code where it is signalling to move.
 

breezy

Arie
Staff member
@carbon

When you jog the machine does the DRO agree with the amount you move it?

Also what is the gearing ratio of your axis? With the machine powered down, rotate a motor one turn by hand how far did the machine move?

Regards,

Arie.
 

carbon

Carbon
Quote from Breezy on December 9, 2019, 12:09 am

@carbon

When you jog the machine does the DRO agree with the amount you move it?

Also what is the gearing ratio of your axis? With the machine powered down, rotate a motor one turn by hand how far did the machine move?

Regards,

Arie.

yes the numbers are all correct measurments
 
Top