Plasma cuts rough circles, Drawing help!

Ross

Ross
Hi, Ross here again.

The problem I am having is to find a way to smooth the radius on corners and circles.

The drawings I produce all end up being segmented on bends, circles and rounded corners, meaning the plasma follows that path and the cuts look not nice!

Drawings that I do the work on is Sketchup mostly or CorelDraw to fix the nodes. other programs I have are AI, Fusion 360 and Art Cam.

If anyone knows how to fix the drawing on any of the mentioned programs so it is not segmented I would like to find out how it is done?

Photos show segments on the Masso screen and how the cuts look bad as well.

Thanks from Ross.

Please note the machine is not the problem, it is the drawing output.
 

Attachments

  • Print-Screen-001.bmp
    769.1 KB · Views: 21
  • IMG_20190719_154726.jpg
    IMG_20190719_154726.jpg
    2.4 MB · Views: 11
  • IMG_20190719_154818.jpg
    IMG_20190719_154818.jpg
    2.6 MB · Views: 16
  • IMG_20190718_151439.jpg
    IMG_20190718_151439.jpg
    3 MB · Views: 9
  • IMG_20190527_132529.jpg
    IMG_20190527_132529.jpg
    2.1 MB · Views: 11

masso-support

MASSO Support
Staff member
@ross your earlier cuts came great that you shared on other forums, just wondering why these are not coming good, what did you change? if you can see what different you are doing now then you can most likely find the cause.
 

Ross

Ross
Things that I have changed,
  • Water table that makes the steel all rusty and splashes water all over the plasma nozzle and other things within a 15cm radius. Think I should have made a vacuum extraction instead!
  • A much Stronger gantry with no vibrations like a guitar string being plucked, as the old design did!

The last photo that is painted black was cut with the old gantry and had the same problem.

The planetary gear box has (cold) .02 movement if I push on the gantry but goes back to .00 when I let go of it, and as it gets hotter from running it gets tighter.

Sorry to say I have no idea how to get fusion 360 to work, can import a DXF but can't do much else with it!

EG: Make the DXF to a solid, can't extrude some parts, smooth edges, it won't produce outside cut lines. and the list goes on forever!

Even after following YouTube videos step by step.

I just need to import a DXF, smooth bends and corners then export to SheetCam to do the G-code.

Maybe some one could do a video to help me.

From Ross.
 

Attachments

  • IMG_20190527_132529.jpg
    IMG_20190527_132529.jpg
    2.1 MB · Views: 11

machinedude

machinedude
I would say it's a resolution issue on arcs in the software your creating your part geometry from. i'm not a fan of DXF files simply because they do some weird stuff when you import the files into another program.
 

machinedude

machinedude



this video shows something similar to what I think you might have going on. it looks like your settings are set for a low resolution possibly.
 

breezy

Arie
Staff member
Quote from Ross on July 20, 2019, 4:10 am

Sorry to say I have no idea how to get fusion 360 to work, can import a DXF but can't do much else with it!

EG: Make the DXF to a solid, can't extrude some parts, smooth edges, it won't produce outside cut lines. and the list goes on forever!

Fusion 360 isn't the best for working on sheet products with imported dxf files!!! But it is doable.

Unless the profile is coloured yellow you can't extrude. Smoothing edges requires a bit of playing in the sketch environment.

Cut lines are inside or outside depending on the direction of the RED arrow when you select your contour, if the cut is on the wrong side just click the RED arrow to reverse it and the cut should shift to the other side of your selected contour .

As "machinedude" said different programs treat dxfs in different ways, so it boils down to the source of the dxf. I have used Fusion to create gCode from a dxf but have now switched to sheetcam for cutting sheet material with dxf files.

I gave up on SketchUp for drawing 3D objects. The most important thing that I did in SketchUp was set the default circle segments to 48 to produce a smoother looking circle.

If you are producing your drawings in SketchUp, up the default circle setting to as high as possible.

Regards,

Arie.
 

testyourdesign

testyourdesign
@ross

Unfortunately many of the free versions of programs draw circles or arcs as polylines made up of a series of segmented lines as you are seeing. In order to improve the quality of the circles in Sketchup you need to increase the number of segments in your circles so that they look more like circles. In Sketchup you can adjust the number of segments in your circle right after starting the command. Look in the bottom RH corner of the screen to see the number of segments it will draw and increase it to make it smoother. For example if your arc is made up of 10 segments try increasing it to 100 segments so that it gets harder to distinguish the points. You can also adjust that value in the Entity Info window by changing the value in the segments box.

This video explains it in a little more detail.


Cheers, Stephen Brown
 

Ross

Ross
Found out something about the problem that I am having.

While searching more about fixing drawings on the web, G-codes came up in one forum.

I have been using the Mach3 processor for all my jobs seeing I use a scribe!

Mach3 that I use hasn't got g1 g2 g3 in it's post processer so it won't smooth out curves.

The Masso has, I did a few washer test cuts and I think I won't need to go to the hardware store any more! Perfect cuts, no dross plus seeing I will probably only be running top speed 5500mm/min I should be able to up the slow down for corners to 100% from 70% after todays tests.

So I can still use Sketchup for drawing, AI mostly or Corel Draw for importing pictures to change to DXF and Corel Draw for reducing nods as well.

Still learning about this, Thanks for all your input on this one, Great!

Will have to open up the old request forum for scribe m-codes again.

From Ross.
 

justingro

Justingro
Hi Ross .

I was just wondering if you ever solved the smooth edges on your text as I also use fusion 360 and have the same problem looks like a saw thooth

Many thanks Justin
 

Ross

Ross
Hi Justin,

I use SheetCam with a Mach3 post processor that i modified. It uses G01 G02 G03 movements. If you read the Masso documents it explains what it is about.

https://docs.masso.com.au/supported-g-codes

Want you have on your circles and curves is a bunch of straight lines, that is the cause of the bad cuts that you have at the moment.

For me with the cutting side of things everything is working correct and i can't see that it needs any more improvements.

Fusion is way beyond me and i have never got it to work, but if you can produce a DXF from it the best way to go is to Buy SheetCam and use my Post processor!

You can contact Masso support "Attention Peter" if you would like to contact me via LINE App. Just ask for a request for Ross Woolley's app Id.

I will be able to show you how i produce the cut files!

Photo shows cut quality on 3 mm steel.

From Ross.
 

Attachments

  • IMG_20200605_102047.jpg
    IMG_20200605_102047.jpg
    4 MB · Views: 11

breezy

Arie
Staff member
Justin,

The default Fusion PP doesn't use G2,G3 commands in some situations, there is a PP floating around that turns G2,G3 on for small arcs.

Search this forum for Fusion plasma PP. I know it's there somewhere because I modified for a member.

Regards,

Arie.
 
Top