Sometimes Spindle Starts, Sometimes it does not! MASSO Folks Help!!

saintb6969

Saintb6969
I have had it up to my ears with some of the bugs in this controller, So far I have broken 5 bits simply because sometimes the spindle will start when I hit cycle start, and sometimes it won't (hence the broken bits). So now I have to babysit the machine every time I start a project simply to make sure the spindle turn on, if not I have to hurry up and click spindle on before it crashes ( not what automation is suppose to be). Anybody have any ideas?

Another issue is that the machine is already moving to the material before the spindle can ramp up to speed (hence more broken bits). Why did they not build in a spindle ramp up delay?

Another issue Sometimes when I complete one file and load another no matter how many times I click cycle start it will not start until I click the re-wind button, even thou it is a new file.

Another issue, why does the touch probe not have a place to input the thickness in order to allow you to touch of the top of the material then deduct the thickness of the probe and set the Z Zero once it has made contact? ( even adding a button to send the machine downward in Z to make contact with the probe for setting Z Zero,probably would have made to much sense to do it that way)

One more Issue, Why does it take so long for the files to load, the DSP loads the same file in about a 1/3 of the time as the MASSO?

I know the majority of this is ranting, but up until installing the MASSO controller, I never had any of theses issues with the cheap Chinese DSP controller, only issue I had with it was no monitor and no way to adjust the feed rate on the go, and so far all I have gotten with the MASSO is a monitor and a bunch of headaches instead of completed projects. I am trying to give it a chance, but I am a frogs hair away from disconnecting the MASSO and going back to the DSP.
 

masso-support

MASSO Support
Staff member
hi @saintb6969 we can help you with resolving the issues.
  1. For the spindle not working issue, as we don't have any reported issues of this nature we will try to first find what's causing this on your machines and is it a wiring/setup issue or a bug in the software. Can you provide controller serial number, software version running on MASSO and your spindle wiring diagram.
  2. Yes, a rewind is always required to clear last commands before starting a new file, so please make sure to click rewind before starting a new file.
  3. Regarding spindle ramp up delay, there is a spindle SPIN UP and SPIN DOWN delay in the F1 spindle settings window, please set the delay as required.
  4. For touch plate, with the current version, its using normal gcode probing cycle and the offset has to be added to your gocde but we are also releasing interactive probing cycles that will have all this done automatically, you can follow the progress here: https://www.masso.com.au/forums/topic/what-do-we-want-to-the-included-in-probe-menu/
  5. The file is loaded immediately and you can press escape key to stop the preview, it's the preview that takes time and can be skipped.
 

saintb6969

Saintb6969
  1. As for the controller SN:2218 V3.41, core 1.26, As for my wiring, it is the same as the delta MS300 you have,
    Delta-MS300-Wiring.jpg
    two wires one MI1 to No 5 and DCM to 6&4. It can not be in the wiring, if so then why does it do it some time and sometimes it doesn't? Why can I manually turn the spindle on with the MASSO controller? I believe it has something to do with the having to hit rewind every time. I have noticed it does it when I am running the same file and I have to restart it for some reason, or sometimes when I load a new file right after finishing up a file on the same project.
  2. Where does it state that I needed to re-wind, or is it one of those things we just need to figure out just like the spindle ramp up and down....
  3. Thought that only applied to when the controller has full control of my VFD...
  4. I will hold off until then before removing the MASSO
 

masso-support

MASSO Support
Staff member
is there a gcode file you can share that if you try to load and run again causes the spindle issue?
 

vend123

New member
hi @saintb6969 we can help you with resolving the issues.
  1. For the spindle not working issue, as we don't have any reported issues of this nature we will try to first find what's causing this on your machines and is it a wiring/setup issue or a bug in the software. Can you provide controller serial number, software version running on MASSO and your spindle wiring diagram.
What was the solution?

I have the same issue "Sometimes Spindle Starts, Sometimes it does not!"

TNX
 

breezy

Arie
Staff member
What was the solution?

I have the same issue "Sometimes Spindle Starts, Sometimes it does not!"

Saintb6969 hasn't posted since his last post here, so we have no idea as to what the solution was.

For us to help you, you need to provide details of your setup.
VDF or Servo driver?
What's the serial number of your controller?
What version of software are you running?

Now common causes are loose or poor termination of the control wiring.
 

vend123

New member
Saintb6969 hasn't posted since his last post here, so we have no idea as to what the solution was.

For us to help you, you need to provide details of your setup.
VDF or Servo driver?
What's the serial number of your controller?
What version of software are you running?

Now common causes are loose or poor termination of the control wiring.
VDF drive.
Controller number G3-5A1SI sn. G3-7375.
Software v. Mill 4-axis v4.01.
 

Attachments

  • 0015.nc
    11.8 KB · Views: 15
Top