struggling to re set up my axis's after new core update and software update

gok

GOK
Hello friend

I don't seem to understand what is happening with my machine. after updating the core and software correctly. my axis's are playing a game with me.

in an email support ticket. it said to communicate in the forum. this is the trouble I was having.

this is what I asked in the ticket:

I just wanted to give you an update to my CNC situation.
after replacing a couple of lever limit switches I re-setup my x, y an z axis's. they move now.
but for the life of me I can not get the machine x, y, z axis's move past the half way position without disabling. the soft and hard limits. I set up the axis's as you instructed me to do in past forum posts. I did not change my dip switches. my info is in the last contact query. did the way we set up the axis's change in the latest core update and software update?

this is what you said.:
the reason for the half movement is that for example if your X axis has a maximum travel of 1000mm and you power up your machine, as the axis can be at any location on power up then controller will show the mid of that axis on power up so that you can manually move the axis as you might need to move the tool away from the job or fixture. Next press CTRL+ALT+HOME to home the machine and that is when the axis will home to its home position.

I spent the day today trying to re-setup the axis's again.(I attached screen shots of were I was when i gave up).
  1. I save the setup after every change, reboot and the numbers keep switching on me.
  2. my max distance on my x and y axis's are 480mm. I tried to setup each axis as o min and 480mm max.
  3. kept switching on me. so I tried -240mm minimum and 240mm max didn't, seem to help.
  4. I thought I had the x axis working correctly after a bit so I saved the changes and rebooted. it stopped working right after I tried to home and the axis's hit the wall. I had the hard and soft limits not disabled at the time.
  5. also for some reason the limit switches don't stop the axis's from over traveling
  6. I don't know what I am doing wrong... I did not seem to be this inept before the updates.

please help!

thanks

George
 

Attachments

  • masso-screens01.jpg
    masso-screens01.jpg
    550.5 KB · Views: 25
  • masso-screens02.jpg
    masso-screens02.jpg
    509 KB · Views: 25
  • masso-screens03.jpg
    masso-screens03.jpg
    623 KB · Views: 23
  • masso-screens04.jpg
    masso-screens04.jpg
    612 KB · Views: 23

masso-support

MASSO Support
Staff member
I am not sure about your switch or sensor outputs but I think this is the core issue as I can see in your screen shots.
  1. Basically for all homing inputs you need to make sure that all homing inputs show LOW when the sensor/switch is not triggered and is away from the axis. If this shows HIGH even if your sensor/switch is away then this will give false signal to MASSO and the homing logic will not work properly.
  2. For your X axis please set it back to Min travel: 0 and Max travel: 480mm.
  3. On power up, as mentioned earlier that the controller does not know where each axis is and will show the mid of each axis as the machine position on power up so that you can jog the axis if needs to be but you must home the machine before you can start using the machine.

Please go through the above points and let us know how you go.
 

gok

GOK
Hello Friend,
thank you for your help. It turned out to be a limit switch problem.
after it hit the wall the first time, the switch I exchanged for a bad one was also bad so it would not home at all with out crashing every time. needless to say i will have extra switches on hand for now one. I just purchased 5 more.



thank you for your help sir.

George
 
Top