Work ofsets

cnc-maker

CNC Maker
OK, I know I am gonna have trouble describing this buy here goes,

When I home the machine to the limit switches, "Machine coordinates" 0,0,0. Then load a Gcode file.

Then lets say I want to cut that file in a different place to "Machine Home".

I jog the machine over to the new spot on the table, including lowering the Z axis, say 50mm.

Then press zero on the X, Y and Z DRO buttons. (G54 is then set)

This is now the new "Home" position of this job

Still with me... LOL

Now if I jog to another position of the table including the Z axis, ( lets say I forgot to change a tool), but I don't press any buttons anywhere

Then press "Go To Work Origon" button (which has saved the job in G54 when I zeroed out all the DRO buttons (including the Z axis)

my machines X and Y axis both move to the pre-saved location on the table, but the Z axis does NOT move at all.

Whats going on please.... or am I just having a seniors moment here



lets see how confusing this thread gets...LOL

\
 

breezy

Arie
Staff member
@cnc-maker

There are a lot of variables here.
  • What values do you have set for G54 in F4 Work Offset list.
  • When you "zero" DRO are you setting F3 WCS DRO's to zero.
  • Does G92 appear in the status line, left bottom of screen.

Then press "Go To Work Origon" button (which has saved the job in G54 when I zeroed out all the DRO buttons (including the Z axis)

my machines X and Y axis both move to the pre-saved location on the table, but the Z axis does NOT move at all.

My interpretation of the "Go to work origin" is move to X & Y "home" position. Which is the same as X0Y0 in MDI. I haven't used GTWO function yet, but will when I have a need to do so.

One possible reason the Z doesn't move is that issuing X0Y0Z0 in MDI will result in the head moving in the most direct route. ie all axis moving towards the requested location for each axis. With a possible crash occurring in the movement.

Regards,

Arie.
 

cncnutz

CNCnutz
Staff member
@cnc-maker @breezy

The Go to work offset doe not move the Z axis, only the X & Y. If you want to move the Z axis to 0 then you need to use MDI.

It is behaving as it should.

Cheers Peter
 

cnc-maker

CNC Maker
Quote from CNCnutz on February 12, 2020, 8:49 am

@cnc-maker @breezy

The Go to work offset doe not move the Z axis, only the X & Y. If you want to move the Z axis to 0 then you need to use MDI.

It is behaving as it should.

Cheers Peter

Thanks Peter,

but like the petulant child that I am :) I have to ask WHY NOT ?

What is the reason the GTWO button does not move the Z axis along with the x and y.

Actually I can think of a couple of reasons, but I will let you no doubt give a far wiser explanation.
 

cncnutz

CNCnutz
Staff member
@cnc-maker



I don't know for sure but I think the answer is as Breezy suggested is to stop you accidently destroying an expensive cutter or material by crashing it into your stock because you forgot to zero it before pressing the GTWO button.

I can say with honesty that I have never broken a carbide cutter while machining a project but I have destroyed more than my air share by crashing them into my stock, clamps and anything else that was on the table.

The last thing I need is a button to do it for me. ;-)



Cheers

Peter
 
Top