Z Axis inverted


Hi just need some advice on Z Axis, today I sent my first code to my Masso powered CNC router table machine from Aspire 8.5

My issue is that when I run the program the Z and Y axis are ok in travel but the Z axis lifts, not plunges from the program, meaning as it is meant to cut into the material the axis actually goes up away from the material

Is this a translator issue a setting or just my plain old ignorance at something ?



Staff member
That usually indicates to you have incorrectly set up the axis calibration.

Check here 20.7.Axis Calibration

From that page

Minimum & Maximum Travel
These values define the size as well as minimum and maximum values of the axis. In most setups this values is between 0.00 and some positive number, but in some cases such as Z axis of a milling machine this value can be negative as the axis home towards the top which is 0.00 but the actual machining happens in the negative direction that is towards the machine bed.

NOTE: The minimum and maximum travel also sets the soft limit of the axis and its very important to set this value with the exact travel of the axis.




MASSO Support
Staff member
Hi Pluggs

When you go into your axis settings you will see a checkbox at the bottom which says invert direction. Just put a check in the box or remove if there is already one there.

Next go into MDI and make sure the Z is moving in the right direction when you issue some move commands eg G0 Z1 will move the axis up and G0 Z-1 will move it down.

If when you home the machine the Z axis now moves in the wrong direction you will need to go into the homing setup and change the direction invert for the Z axis.

Hope this helps